import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "3(?:\\.\\d+)*\\.\\s*";
final String string = "3.1. Cre\n"
+ "3.1.1. Im\n"
+ "3.1.1.1. O\n"
+ "3.1.1.2. Ce\n"
+ "3.1.1.3. Part\n"
+ "3.1.2. ED\n"
+ "3.1.2.1. Ow\n"
+ "3.1.2.2. ED\n"
+ "3.1.3. OF\n"
+ "3.1.3.1. O\n"
+ "3.1.3.2. O\n"
+ "3.1.3.3. O\n"
+ "3.1.3.4. O\n"
+ "3.1.4. Sc\n"
+ "3.1.5. In\n"
+ "3.1.6. Vi\n"
+ "3.1.7. Bu\n"
+ "3.1.8. Ho\n"
+ "3.1.8.1. Ou\n"
+ "3.1.8.2. In\n"
+ "3.1.9. Pa\n"
+ "3.1.9.1. Re\n"
+ "3.1.9.2. Re\n"
+ "3.1.9.3. Pr\n"
+ "3.1.9.3.1. Ou\n"
+ "3.1.9.3.2. Sp\n"
+ "3.1.9.3.3. In\n"
+ "3.1.9.3.4. In";
final String subst = "\\t";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}