$re = '/(.+)/m';
$str = 'https://regex101.com/r/wU7sQ0/6';
$subst = "\1#python";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;