$re = '/^(([\€\$\¥\£]\s?)(\d{1,3}[.](\d{3}[.])*\d{3}|\d+)([,]\d{1,2})?)|((\d{1,3}[.](\d{3}[.])*\d{3}|\d+)([,]\d{1,2})?(\s?[\€\$\¥\£])?)$/';
$str = '$ 3.333,00';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);