re = /^(([\€\$\¥\£]\s?)(\d{1,3}[.](\d{3}[.])*\d{3}|\d+)([,]\d{1,2})?)|((\d{1,3}[.](\d{3}[.])*\d{3}|\d+)([,]\d{1,2})?(\s?[\€\$\¥\£])?)$/
str = '$ 3.333,00'
# Print the match result
str.match(re) do |match|
puts match.to_s
end