import re
regex = re.compile(r"(?m)^Ingredients\R((?>(?!Ingredients$).*\R)+?)Preparation$")
test_str = ("Recipes & Menus\n"
"Expert Advice\n"
"Ingredients\n"
"Holidays & Events\n"
"Community\n"
"Video\n"
"SUMMER COOKING\n"
"Lentil and Brown Rice Soup\n"
"Gourmet January 1991\n"
"3.5/4\n"
"reviews (83)\n"
"90%\n"
"make it again\n"
"Some soups genuinely do inspire a devotion akin to love, and this is one of\n"
"them. In the cold of winter, when Gourmet editors ponder the matter of what soup\n"
"Cook\n"
"Reviews (83)\n"
"YIELD: Makes about 14 cups, serving 6 to 8\n"
"Ingredients\n"
"5 cups chicken broth\n"
"1 1/2 cups lentils, picked over and rinsed\n"
"1 cup brown rice\n"
"a 32- to 35-ounce can tomatoes, drained, reserving the juice, and chopped\n"
"3 carrots, halved lengthwise and cut crosswise into 1/4-inch pieces\n"
"1 onion, chopped\n"
"1 stalk of celery, chopped\n"
"3 garlic cloves, minced\n"
"1/2 teaspoon crumbled dried basil\n"
"1/2 teaspoon crumbled dried orégano\n"
"1/4 teaspoon crumbled dried thyme\n"
"1 bay leaf\n"
"1/2 cup minced fresh parsley leaves\n"
"2 tablespoons cider vinegar, or to taste\n"
"Preparation\n"
"In a heavy kettle combine the broth, 3 cups water, the lentils, the rice, the tomatoes with the reserved juice,")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")