using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.{1,42}$)^(?!-)(?!.*--)^(\s?\.?[a-zA-Z]+)+$";
string input = @"space.ooo.o-oo.oo";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}