re = /^(?=.{1,42}$)^(?!-)(?!.*--)^(\s?\.?[a-zA-Z]+)+$/
str = 'space.ooo.o-oo.oo'
# Print the match result
str.match(re) do |match|
puts match.to_s
end