using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @",(?![^(]*\))";
string substitution = @"\n";
string input = @"foo (foo, foofoo), bar (foobar), foo, bar (barbar, foo), bar, foo";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}