$re = '/,(?![^(]*\))/';
$str = 'foo (foo, foofoo), bar (foobar), foo, bar (barbar, foo), bar, foo';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;