package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^[a-z]\w+$`)
var str = `would match
ab1
bc_1
would not match
1_bc
1ab`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}