$re = '/^[a-z]\w+$/mi';
$str = 'would match
ab1
bc_1
would not match
1_bc
1ab';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);