package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\"[^\"]*\")|(})`)
var str = `if (true){var data = string.Format(\"something {0} {1}.\", \"is\", \"wrong\");}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}