$re = '/^(?=(?P<word1>.*Tim))(?=(?P<word2>.*stupid)).+/im';
$str = 'Tim stupid
stupid Tim';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);