re = /^(?=(?P<word1>.*Tim))(?=(?P<word2>.*stupid)).+/im
str = 'Tim stupid
stupid Tim'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end