package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`help::[\r\n\t\f ]*(.*?)[\r\n\t\f ]*?(?:\*\/|-->)`)
var str = `/* help::this is my comment */
<!-- help:: this is my other comment -->`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}