re = /help::[\r\n\t\f ]*(.*?)[\r\n\t\f ]*?(?:\*\/|-->)/
str = '/* help::this is my comment */
<!-- help:: this is my other comment -->'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end