const regex = /^https?:\/\/(?:www\.|m\.)?youtube\.com\/watch.*?[?&]v=([\w\-]+)/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^https?:\\\/\\\/(?:www\\.|m\\.)?youtube\\.com\\\/watch.*?[?&]v=([\\w\\-]+)', 'i')
const str = `https://www.youtube.com/watch?v=lugnetyBAhc`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}