re = /^https?:\/\/(?:www\.|m\.)?youtube\.com\/watch.*?[?&]v=([\w\-]+)/i
str = 'https://www.youtube.com/watch?v=lugnetyBAhc'
# Print the match result
str.match(re) do |match|
puts match.to_s
end