import re
regex = re.compile(r"(['\"])(?:(?!\1)[\s\S])+\1")
test_str = ("We are looking for phrases within quotes and it can be multiline \"check we have a return here but this line is still part of previous one 'a' string\".\n\n"
"It breaks once we have another 'testing with single quotes \"surrounding\" double quotes';")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")