re = /(['"])(?:(?!\1)[\s\S])+\1/
str = 'We are looking for phrases within quotes and it can be multiline "check we have a return here but this line is still part of previous one \'a\' string".
It breaks once we have another \'testing with single quotes "surrounding" double quotes\';'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end