#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(['"])(?:\\[\s\S]|(?!\1)[^\\])*?\1"
Local $sString = "We are looking for phrases within quotes and it can be multiline "check we have a \"return\" here but this line is still part of previous one 'a' string"." & @CRLF & _
"" & @CRLF & _
"It breaks once we have another 'testing with single \'quotes\' "surrounding" double quotes';"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")