import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(['\"])(?:\\\\[\\s\\S]|(?!\\1)[^\\\\])*?\\1";
final String string = "We are looking for phrases within quotes and it can be multiline \"check we have a \\\"return\\\" here but this line is still part of previous one 'a' string\".\n\n"
+ "It breaks once we have another 'testing with single \\'quotes\\' \"surrounding\" double quotes';";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}