const regex = /\/activity\/post\/(\w+)\/comment\/(\w+)$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/activity\\\/post\\\/(\\w+)\\\/comment\\\/(\\w+)$', '')
const str = `/activity/post/1/comment/2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}