re = /\/activity\/post\/(\w+)\/comment\/(\w+)$/
str = '/activity/post/1/comment/2'
# Print the match result
str.match(re) do |match|
puts match.to_s
end