import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(http|https):\\/\\/[\\d\\w]{1,64}\\.?[\\d\\w]{2,15}(\\/[\\d\\w]*)*\\??[\\d\\w&=]*$";
final String string = "http://localhost.com/test/asSf?test=est&test";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}