re = /^(http|https):\/\/[\d\w]{1,64}\.?[\d\w]{2,15}(\/[\d\w]*)*\??[\d\w&=]*$/i
str = 'http://localhost.com/test/asSf?test=est&test'
# Print the match result
str.match(re) do |match|
puts match.to_s
end