const regex = new RegExp('(.*?)\\s(\\d{1,2})(?::(\\d{1,2})(?:-(\\d{1,2})?)?)?', '')
const str = `2 Timothy 28:10-11`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}