const regex = /(.*?>)(?=(?:.*?\1)+$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*?>)(?=(?:.*?\\1)+$)', 'gm')
const str = `foo B7R, B9R, B12R, B12M 430mm Disc 2005 > foo B7R, B9R, B12R, B12M 430mm Disc 2005 >B7R, B9R, B12R, B12M 430mm Disc 2005 >B7R, B9R, B12R, B12M 430mm Disc 2005 >B7R, B9R, B12R, B12M 430mm Disc 2005 >B7R, B9R, B12R, B12M 430mm Disc 2005 >`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);