$re = '/(.*?>)(?=(?:.*?\1)+$)/m';
$str = 'foo B7R, B9R, B12R, B12M 430mm Disc 2005 > foo B7R, B9R, B12R, B12M 430mm Disc 2005 >B7R, B9R, B12R, B12M 430mm Disc 2005 >B7R, B9R, B12R, B12M 430mm Disc 2005 >B7R, B9R, B12R, B12M 430mm Disc 2005 >B7R, B9R, B12R, B12M 430mm Disc 2005 >';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;