using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^\s#]+";
string input = @"sun #plants #!wood% ##arebaba#tey travel#blessed #weed das#$#F!@D!AAAA";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}