package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^\s#]+`)
var str = `sun #plants #!wood% ##arebaba#tey travel#blessed #weed das#$#F!@D!AAAA`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}