#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\([0-9]{2}\)\s?[0-9]{4,5}-?[0-9]{3,4})|([0-9]{10,11})|([0-9]{2}\s?[0-9]{8,9})"
Local $sString = "(99) 99999-9999" & @CRLF & _
"(99)99999-9999" & @CRLF & _
"(99)9999-9999" & @CRLF & _
"(99)99999-999" & @CRLF & _
"99 999999999" & @CRLF & _
"99 99999999" & @CRLF & _
"99999999999" & @CRLF & _
"9999999999" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")