re = /(\([0-9]{2}\)\s?[0-9]{4,5}-?[0-9]{3,4})|([0-9]{10,11})|([0-9]{2}\s?[0-9]{8,9})/m
str = '(99) 99999-9999
(99)99999-9999
(99)9999-9999
(99)99999-999
99 999999999
99 99999999
99999999999
9999999999
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end