import re
regex = re.compile(r"^https?:\/{2}regex101\.com\/r\/([a-zA-Z0-9]{6})(?:\/(\d+)?)", flags=re.MULTILINE)
test_str = ("http://regex101.com/r/mH1fN5\n"
"https://regex101.com/r/fW0vZ2\n"
"https://regex101.com/r/wY0rM7/3\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")