import re
regex = re.compile(r"\+?(1?)[\(\s]*([2-9]\d{2})[\s\)]*(\d{3})[\s-]*(\d{4})")
test_str = ("12345678900\n"
"514 706 0306\n"
"514 706-0306\n"
"(514) 706-0306\n"
"+1 514 7090306\n"
"15147060306")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")