$re = '/load((?:\w+)+)/';
$str = 'load filename1 filename2 filename2 filename2 filename2';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);