re = /load((?:\w+)+)/
str = 'load filename1 filename2 filename2 filename2 filename2'
# Print the match result
str.match(re) do |match|
puts match.to_s
end