using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"a+b+u+r+(?:i+(?:(?:d+)|(?:m+i+e+n+t+)))?o+";
string input = @"me aburrooooo
estoy abbbuuurrriiiiddooooo
que aburrrimieeeennto!!!
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}