$re = '/a+b+u+r+(?:i+(?:(?:d+)|(?:m+i+e+n+t+)))?o+/i';
$str = 'me aburrooooo
estoy abbbuuurrriiiiddooooo
que aburrrimieeeennto!!!
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);