# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"window[^}]*}"
test_str = ("<td>5589043</td><td>UNPublished</td><td>SNK-300-SNORKEL</td><td>0</td><td>Tribord</td><td>542</td><td>433</td><td>14.5</td><td>Adult</td><td>any</td><td>window.onload = function(){window.parent.CKEDITOR._[\"contentDomReadyattribute85\"]( window );}</td><td>\n"
" snorkelers and scuba divers.\n"
"</td><td>window.onload = function(){window.parent.CKEDITOR._[\"contentDomReadyattribute111\"]( window );}</td><td>2</td><td></td><td>FALSE</td><td>5000</td><td>128</td><td>MASKS & SNORKELS</td><td>11</td><td>Diving</td><td>519713</td><td>White</td><td></td><td>http://test.com/image/products/p_3358/zoom_asset_7454285.jpg</td><td>Freedom of movement</td><td>\n"
" Soft hypollergenic black silicone mouthpiece.\n"
"</td><td>Maintenance</td><td></td><td>Reduced chafing</td><td>\n"
" 100% phthalate-free PVC tube, 100% silicone mouthpiece.\n"
"</td><td>Technical</td><td></td><td>Easy storage</td><td>\n"
" Flexible tube that can positioned between mask strap and forehead.\n\n\n"
"</td><td>Composition</td><td>\n"
" salt water resistant. Only rinse with fresh water before prolonged storage.\n"
"</td><td>Comfortable</td><td>\n"
" Soft hypollergenic black silicone mouthpiece.\n"
"</td><td>Easy breathing</td><td></td><td>Anatomic design</td><td>\n"
" Flexible tube that can positioned between mask strap and forehead.\n\n\n"
"</td><td>Care Instructions</td><td>\n"
" salt water resistant. Only rinse with fresh water before prolonged storage.\n"
"</td><td>Mouth piece</td><td></td><td>Restriction of use</td><td></td><td>http://test.com/image/products/p_3358/zoom_asset_33225717.jpg</td><td>http://test.com/image/products/p_3358/zoom_asset_30448342.jpg</td><td>http://test.com/image/products/p_3358/zoom_asset_19099347.jpg</td><td></td><td></td><td></td><td></td><td></td><td></td><td></td><td></td><td></td><td></td><td></td><td></td><td></td><td></td><td></td><td></td><td></td></tr><tr><td>3359</td><td>2014-01-09 18:32:31</td><td>8174997</td><td>Published</td><td>DYNAMO-LAMP</td><td>90</td><td>Tribord</td><td>999</td><td>649</td><td>14.5</td><td>Any</td><td>any</td><td></td><td>\n"
" Snorkelling.Watertight to 5m, eco-friendly and economical.\n"
"</td><td></td><td>2</td><td></td><td>FALSE</td><td>333.7</td><td>129</td><td>SNORKELING KITS</td><td>11</td><td>Diving</td><td>1349256</td><td>Black</td><td></td><td>http://test.com/image/products/p_3359/big_800PX_29672977a.jpg</td><td>Battery</td><td>\n"
" 3 modes: Blinking, eco-friendly, and 100% (100% = 10minutes after 1min charge)\n"
"</td><td>Features</td><td></td><td>Swimming Depth</td><td>")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.