const regex = /^(\d+\.?\d*)(h|m|s|ms|f|t)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d+\\.?\\d*)(h|m|s|ms|f|t)$', 'gm')
const str = `11
11s
11.1222s
33ms
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}