import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<div class=\"user.*\">(.*)<\\/div>";
final String string = "<div class=\"user\">\n"
+ " <div class=\"user__logo\">asdasd</div>\n"
+ " <div class=\"user__name\">asdad</div>\n"
+ " <div class=\"user__rating\">asdasd</div>\n"
+ "</div>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}