$re = '/<div class="user.*">(.*)<\/div>/';
$str = '<div class="user">
<div class="user__logo">asdasd</div>
<div class="user__name">asdad</div>
<div class="user__rating">asdasd</div>
</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);