using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\+?\d{1,4}?[-.\s]?\(?\d{1,3}?\)?[-.\s]?\d{1,4}[-.\s]?\d{1,4}[-.\s]?\d{1,9}";
string input = @"+49 172 7470791
+49 621 60-6641516
+49 621 60-41516
8-1-6641516
61 41516
6641516
41516 ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}