package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\+?\d{1,4}?[-.\s]?\(?\d{1,3}?\)?[-.\s]?\d{1,4}[-.\s]?\d{1,4}[-.\s]?\d{1,9}`)
var str = `+49 172 7470791
+49 621 60-6641516
+49 621 60-41516
8-1-6641516
61 41516
6641516
41516 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}