#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:([+]\d{1,4})[-.\s]?)?(?:[(](\d{1,3})[)][-.\s]?)?(\d{1,4})[-.\s]?(\d{1,4})[-.\s]?(\d{1,9})"
Local $sString = "+49 172 7470791 " & @CRLF & _
"+49 621 60-6641516 " & @CRLF & _
"+49 621 60-41516 " & @CRLF & _
"8-1-6641516 " & @CRLF & _
"61 41516 " & @CRLF & _
"6641516 " & @CRLF & _
"41516 " & @CRLF & _
"+1(1111" & @CRLF & _
"+()1111"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")