import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[\\s\\S]{0,30}";
final String string = "</head>\n"
+ "<body>\n"
+ "<div id=\"kJAQ_\" class=\"z-temp\"><div id=\"zk_proc\" class=\"z-loading\"><div class=\"z-loading-indicator\"><span class=\"z-loading-icon\"></span>Processing...</div></div></div>\n"
+ "<script class=\"z-runonce\" type=\"text/javascript\">\n"
+ "zkmx(\n"
+ "[0,'kJAQ_',{dt:'z_oec',cu:'/EfectoresWeb',uu:'/EfectoresWeb/zkau',ru:'/login.isp'},[\n"
+ "['zul.utl.Style','zk_comp_1',{visible:false,src:'/EfectoresWeb/css/PamiStyle.css'},[]],\n"
+ "['zul.wgt.Div','zk_comp_2',{id:'div',style:'width:90%;margin:0 auto 0 auto;align:center',prolog:'\\n\\t'},[\n"
+ "['zul.wgt.Include','zk_comp_3',{prolog:'\\n\\t\\t',_xcnt:'<div id=\"kJAQ0\" class=\"z-temp\"><div id=\"zk_proc\" class=\"z-loading\"><div class=\"z-loading-indicator\"><span class=\"z-loading-icon\"></span>Processing...</div></div></div>',_childjs:function(){zkmx(\n"
+ "[0,'kJAQ0',{ow:'zk_comp_3'},[\n"
+ "['zul.wnd.Window','zk_comp_38',{id:'winHeader',$$onSize:false,$$onMaximize:false,$$onOpen:false,$$onMinimize:false,$$onZIndex:false,$onClose:true,$$onMove:false,prolog:'\\n\\t'},[\n"
+ "['zul.box.Box','zk_comp_39',{},[\n"
+ "['zul.box.Box','zk_comp_40',{id:'hbox_header',align:'end'},[\n"
+ "['zul.wgt.Image','zk_comp_41',{src:'/EfectoresWeb/img/top.jpg'},[]]],'horizontal']],'vertical']]]]]);\n"
+ "}},[]],\n"
+ "['zul.wnd.Window','zk_comp_4',{id:'winLogin',$onOK:true,$onClose:true,prolog:'\\n\\t \\t'},[\n"
+ "['zul.box.Box','zk_comp_5',{},[\n"
+ "['zul.box.Box','zk_comp_6',{id:'hbox_menu'},[],'horizontal'],\n"
+ "['zul.wgt.Groupbox','zk_comp_7',{$$onOpen:false,width:'890px',closable:false},[\n"
+ "['zul.wgt.Caption','zk_comp_8',{id:'caption_login',sclass:'z-title',label:'Login'},[]],\n"
+ "['zul.grid.Grid','zk_comp_9',{$$onRender:true,$";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}