package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.+?)(,|$)`)
var str = `test,test,test`
var substitution = ""$1"$2 "
fmt.Println(re.ReplaceAllString(str, substitution))
}