const regex = /^(\w+) (?=(?|-.*\[([^]]+)\]|\[([^]]+)\])).*? ((?:\d+\.){3}\d+) \[([^]]+)\]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\w+) (?=(?|-.*\\[([^]]+)\\]|\\[([^]]+)\\])).*? ((?:\\d+\\.){3}\\d+) \\[([^]]+)\\]', 'gm')
const str = `asdf - 10.0.0.1 [stuff] [xRelevantStuffx]
asdf [yRelevantStuffy] 10.0.0.1 [stuff] [xRelevantStuffx]
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}