re = /^(\w+) (?=(?|-.*\[([^]]+)\]|\[([^]]+)\])).*? ((?:\d+\.){3}\d+) \[([^]]+)\]/m
str = 'asdf - 10.0.0.1 [stuff] [xRelevantStuffx]
asdf [yRelevantStuffy] 10.0.0.1 [stuff] [xRelevantStuffx]
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end